0 votes

Hi

I've found a small problem in 2021.1 where approval emails for a task are being sent to the onmicrosft.com email address of the approvers not their actual email address. This is only causing us an issue because we're in the process of integrating another company and have user objects for the other company in our domain but without the routing email being set (we're very complcated!!).

The only reason I have figured this out is because we use Mimecast which shows a log of all emails image.png

The emails are being delivered to the internal recipients, but the 'special' users without the remote routing address don't receive it. I've just tested the same in 2023 and get the same results. Is there a way to force Adaxes to use the email attribute for these, not the remote routing address?

There are some examples of emails going to the email address, such as scheduled reports and test emails, these show up in Mimecast just as the users name, no email address.

Thanks

Matt

by (2.0k points)

1 Answer

0 votes
by (272k points)
selected by
Best answer

Hello Matt,

There is no need to force Adaxes to always use the Email property to take delivery addresses from. It is always used and it is the only one used for approval requests. At the same time, Adaxes itself does not deliver email notifications. It only sends requests to the SMTP server you specify. We recommend you to check the settings and logs on the server. Unfortunately, we have no possibility to suggest any root cause/solution as this is not something caused by Adaxes.

0

Hello Matt,

Are you actually able to see the accounts in Adaxes? If not, make sure they are not in the unmanaged list.

0

Yes, they are being shown in Adaxes. I've just tried tried adding the mail user directly to the approval but still it seems no emails are being sent out.

image.png

+1

Hello Matt,

In this case Adaxes does send the requests for email delivery. It does not check anything except for the email property. We recommend you to check Exchange logs and the logs of your SMTP server. Most probably there is some issue with the emails delivery. Also, you can check Adaxes event log: https://www.adaxes.com/help/ServiceEventLog. However, it will only contain related records in case sending an email failed initially. Such a thing can only happen if an approver does not have an email specified or the SMTP server returned an error.

0

I have the same issue occurring. If i test the email function on the settings screen it emails properly when I pick my user to my email address. If i setup a report and have it email to myself it chooses my on.microsoft address for some reason it seems and the email doesn't get delivered to my actual email inbox.

0

Hello,

All Adaxes does is take the value of the Email property and send a request to the specified SMTP server to deliver the report to the obtained address. Adaxes itself does not deliver emails at all. We recommend you to check the behaviour with Microsoft support. They should be able to explain the whore route.

Related questions

0 votes
1 answer

When creating a hybrid user mailbox with a Business Rule, after user creation, the remote routing address of the mailbox is set to the users email alias. How do I set it to the 365 address username@ourdomain.mail.onmicrosoft.com

asked Apr 13, 2022 by john.harding (70 points)
0 votes
1 answer

I have people stating they never received the approval notifications. I know how to add multiple approvers to a Send for Approval command, but that sends a email to a second " ... do I send a duplicate email or CC another user on ALL outbound emails? Thanks!

asked Oct 24, 2012 by mpaul (360 points)
0 votes
1 answer

Hello, I'm wondering if it's possible to export a list of all users in AD along with their email addresses to an Excel spreadsheet and then schedule that export to append ... address that wasn't previously used. Please let me know if this is possible. Thanks!

asked Apr 11 by sjjb2024 (60 points)
0 votes
1 answer

The default pattern format we need should be :First letter of User firstname concatinated to user lastname and pd.sandiego.gov as in jdoe@pd.sandiego.gov

asked Jan 23 by hhsmith (40 points)
0 votes
1 answer

My security team is looking to do a security review and would like the vendor to fill out a questionnaire.

asked Aug 25, 2023 by LarrySargent (20 points)
3,346 questions
3,047 answers
7,782 comments
544,996 users