0 votes

I am unable to install adaxes web feature on win 2016 server core, because the installer complains of web-mgmt-console feature missing.

why is web-mgmt-console necessary in the first place?

now, adaxes is an excellent product, but i think it is really critical that it works on server core (or better still, nano!). the desktop version of windows server takes too much resources, needs constant updates and reboots, and its gui is totally not needed when what i want is access from a web portal.

i really hope the adaxes dev team can hear me on this. even ms made exchange 2019 runs on core, so this is definitely the way to go in the future.

all other roles installs without a hitch on server core. ironically, server console actually works on server core.

ps./ some roles are missing too: NetFx4-AdvSrvs and IIS-ManagementConsole

by (50 points)
0

Hello,

Thank you for pointing this out to us. We will investigate the issue and get back to you as soon as there are any updates.

0

tks. i look forward to a new build that can run on server core!

i am happy to beta test :D

1 Answer

0 votes
by (233k points)
selected by
Best answer

Hello,

We have created a custom build that includes a fix for the issue. You can download it here.

Upgrade Instructions

0

you guys are awesome! will try right away and report my findings!

0

Prelude:
I have a vm running server core 2016 with adds installed. This vm acts as my pdc.

I now create a new vm, also running server core 2016. I domain joined this vm to my pdc. then i installed adaxes 2018.1 x64 on it.

The 'web' component doesn't work.

Steps:
1. i copied the new msi to c:\ of my vm running server core. This vm had the service and server console role installed.
2. Ran msi and chose 'change'. Added 'web' component.
3. Install failed: Specific account already exists
4. Ran msi again and chose 'repair'. Same error.
5. Ran again. Chose uninstall. Uninstall successful.
6. Ran again. Install service, server console and web components.
7. When prompted for ad account, i used the one created previously.
8. Noticed that the service page now has the 'use existing service' enabled. I chose the create new service ption.
9. Install successful.
10. visit http://<hostname>/Adaxes and logon
11. tried creating a new user and it says access is denied. is my service configured properly?

0

Hello,

It looks like the installation went fine. Most probably, the issue occurs because the account whose credentials were used to sign in to the Web Interface has no permissions to create new users. For information on how to grant the permissions, have a look at the following tutorial: https://www.adaxes.com/tutorials_Delega ... eUsers.htm.

Related questions

0 votes
1 answer

My iis webserver clusters are all running Windows Server Core 2016. Trying to install the MSI throws an error saying IE6 required. Is IE6 necessary in any way? I thought it ... to bypass this so that I can install Adaxes into server core? Thanks in advance.

asked Apr 3, 2017 by kwakerdark (50 points)
0 votes
1 answer

Hi, How do I Install the web Interface Configuration console on workstations to manage the service on the Adaxes server? I'd like to configure the portal without the need to ... to install IIS on the client. I think I'm missing something here. Regards Thomas

asked May 15, 2013 by cunningham57906 (40 points)
0 votes
1 answer

I have a Property Pattern that uses Office as a drop down list. I have it defaulted to one of the items in the list. I have setup Office to be a required field ... as a required field. Is it possible to make Office show up during user account creation?

asked Aug 17, 2020 by ComputerHabit (790 points)
0 votes
1 answer

I'm currently receiving the below error when trying to remove or add actions to a web interface's homepage. I only get the error on this specific dashboard, others are ... the web interface there. I'm currently running Adaxes version 2021.1 if that helps

asked May 21, 2021 by richarddewis (260 points)
0 votes
1 answer

We have 4 om prem servers to setup Adaxes on, we currently have almost everything on one server but have crashed on several occassions when multiple scheduled jobs are ... way to achieve this configuration without having to buy double the licenses. Thanks' Jay

asked Sep 24, 2021 by willy-wally (3.2k points)
2,883 questions
2,602 answers
6,755 comments
118,257 users