0 votes

I have a business rule that moves a users account to different OU's based on it's value e.g. when set as 'Normal' the account is moved to the 'Normal User' OU, and when set as 'Admin' the account is moved to the 'Admin User' OU.

The issue I have is that, if I change this value (which can be set as part of creating an account, or modifying it in future) via the web portal, and this results in the account moving, I get an error after 'saving' as the portal tries to reload the object details for an object that is no longer where it was when opening it.

Is there any way round this? I know I can create a Home Page action instead that bypasses the 'current object reload' condition, but was wondering if there is any other way to construct the underlying business rule to take this issue into account?

Regards

by (1.6k points)
0

Hello,

Web Interface correctly handles the situation when a user is automatically moved to another OU during creation or modification. Can you provide more details on what you are doing and post a screenshot with the error?

0

Hi,

We did a bit more testing and it indeed worked.

I think the original failure was because I was testing on the same account that had been used to logon to the portal - will confirm that is the case, but you are right that the web UI can handle this condition.

Rgds

0

I am having the same problem. I have a business rule that triggers after successfully creating a user that moves it to the correct OU using a Template of OU=%adm-CustomAttributeText4%,%adm-ParentDN%. The user gets created and moved ok, but the web interface errors with "Object does not exist" when trying to display the created user (underneath the Operation Succeeded and Execution Log.

The previous post implies this should work ok?

0

Hello,

Yes, such a situation should be correctly handled by Adaxes Web Interface. Could you post a screenshot of the error message?

Also, could you test this being logged in to the Web interface with credentials of Adaxes default service administrator (the user that you specified when installing Adaxes)?

Please log in or register to answer this question.

Related questions

0 votes
1 answer

Hello. I'm fairy new with script on in Adaxes but like to make a business rule that moves computer to the correct OU and set an extended attribute with a numeric value. I found ... 2. How do I get that. Is there a smarter way to place computers in correct OU?

asked Mar 4, 2015 by Klas (460 points)
0 votes
1 answer

Hi, Still struggling with blind user role :-) i found out that i cannot exclude configuration object from the role (this is greyed) so users cannot use "My Approval" "My requests" features Is this normal ? TIA

asked Jul 21, 2011 by sroux (800 points)
0 votes
1 answer

On scheduled tasks, business rules, and custom commands, inside an if statement, you have the option for it to be "AND" or "OR" in the condition. Can there be a ... a bunch of computer accounts to be deleted. We think this would be a good safety measure.

asked Mar 22, 2021 by mark.it.admin (2.0k points)
0 votes
1 answer

When creating business rules I quite often find myself having to create overly complex workflows because we can't use ELSE or BREAK statements. An example would be:- ... am I missing something in how to construct business rules that mimics their use? Thanks

asked Sep 23, 2014 by firegoblin (1.6k points)
0 votes
1 answer

Hi again, My user object creation process use many business rules, one of these moving the object to the right container according to somme attributes. The problem is that sometimes, ... . I run the latest version of Adaxes (3.2.7831). Thanks for your help

asked Feb 10, 2012 by sroux (800 points)
2,779 questions
2,512 answers
6,574 comments
26,276 users