0 votes

Hi again-

When I attempt to test the deprovision command, I get the msg "the specified custom command doesn't exist".
Can't seem to figure this out.
Initially I did a copy and disabled, but after enabling it, no cigar.

I tried all the web interfaces and they all get the same message when clicking the deprovision button.

I checked the security roles and "execute custom commands" is enabled.
I also restored to Initial state.

by (1.7k points)

1 Answer

0 votes
by (18k points)
selected by
Best answer

Hello,

It looks like you deleted the built-in Deprovision command and created another one with the same name. Custom Commands are referred to using their unique IDs, not names. So, if you want to use your command instead of the built-in one, you need to delete the old home page action and create a new one that will execute your custom command:

  1. On the computer, where the Web Interface is installed, start the Web Interface Customization tool.
  2. In the Interface type drop-down list, select the Web Interface that you want to configure.
  3. On the General tab, click Configure Home Page Actions.
  4. Delete the Deprovision action from the list.
  5. Click Add and follow the following steps to create a new action that will execute your command: http://www.adaxes.com/tutorials_WebInte ... #executecc

BTW, if you need to restore the built-in command, right-click the Builtin container located under Custom Commands, and select Restore Built-in Objects:

0

Thanks Eugene! That worked.

Related questions

0 votes
1 answer

Good afternoon, I am attempting to create a report to flag Users where the email address in AD does not match the email address in our Payroll system. I am able to use ... ) to grab User objects. Any help or input would be greatly appreciated. Thank you, Keith

asked Aug 12, 2021 by kfrench (20 points)
0 votes
1 answer

I'm currently receiving the below error when trying to remove or add actions to a web interface's homepage. I only get the error on this specific dashboard, others are ... the web interface there. I'm currently running Adaxes version 2021.1 if that helps

asked May 21, 2021 by richarddewis (240 points)
0 votes
1 answer

Hi, we're receiving the below error when trying to add SMTP addresses to Office365 mailboxes from Adaxes. I've raised a ticket with support, but thought I'd ask ... , please see exception members for more information. Any help would be great. Thanks Gary

asked May 29, 2020 by gazoco (390 points)
0 votes
1 answer

Hello, I am trying to figure out how to create a scheduled task via PowerShell. I've been referencing the SDK, mostly pulling script examples straight out of it. After following the steps on ... ==================> # Save the Scheduled Task $task.SetInfo()

asked Feb 23, 2015 by DFassett (710 points)
0 votes
1 answer

Trying to create a new group and getting the following error: "The name reference is invalid. (Server: example.com)" I've created groups before...the problem seems to have just ... a new Group object. It has me puzzled so I'm looking for some direction...

asked Feb 28, 2014 by RickWaukCo (300 points)
2,756 questions
2,490 answers
6,522 comments
1,458,845 users