0 votes

I'm moving from 2013.1 (on Server 2008 R2) to 2014.1 (on Server 2012 R2) and am going from a single server to 2 new servers and will shut down the 2013.1 server when I get this completed.

I installed Adaxes on one server and had it share it's configuration from the 2013.1 server with no issues and it's been up for a couple of weeks.

I'm now installing a second server so we can do load balancing for 2014.1 with our F5's to these two new servers, however, during the install, it's giving me an error:

Add error on entry starting on line 17: Operations Error

The server side error is 0x21a2 The FSMO role ownership could not be verified because its directory partition has not replicated successfully with at least one replication partner. The extended server error is:000021A2:...

It then rolls back the installation.

In looking at the event viewer for the new server, I see this error:

The directory server has failed to update the host name and/or ports information for this service on the following remote server. This operation will be retried. Other directory servers in this configuration set (if any) will be unable to replicate changes from this directory server until this change is performed and replicated to them.

Additional Data
Target DSA object:
CN=NTDS Settings,CN=<SERVER>$AdaxesBackend,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,CN={A95E89DB-8B8F-45AF-8428-BE9FF17D0490}
Error value:
8601 The remote create cross reference operation failed on the Domain Naming Master FSMO. The operation's error is in the extended data.
Internal ID:

How do I fix this?

** edit **
On the server it's mentioning (the 2013.1), I'm seeing this error (and it just started after the server was rebooted last week).

Log Name: ADAM (AdaxesBackend)
Source: ADAM [AdaxesBackend] Replication
Date: 8/23/2014 1:01:53 AM
Event ID: 2092
Task Category: Replication
Level: Warning
Keywords: Classic
Computer: <2013.1 server>.tasconline.com

This server is the owner of the following FSMO role, but does not consider it valid. For the partition which contains the FSMO, this server has not replicated successfully with any of its partners since this server has been restarted. Replication errors are preventing validation of this role.

Operations which require contacting a FSMO operation master will fail until this condition is corrected.

FSMO Role: CN=Schema,CN=Configuration,CN={A95E89DB-8B8F-45AF-8428-BE9FF17D0490}

User Action:

1. Initial synchronization is the first early replications done by a system as it is starting. A failure to initially synchronize may explain why a FSMO role cannot be validated. This process is explained in KB article 305476.
2. This server has one or more replication partners, and replication is failing for all of these partners. Use the command repadmin /showrepl to display the replication errors. Correct the error in question. For example there maybe problems with IP connectivity, DNS name resolution, or security authentication that are preventing successful replication.
3. In the rare event that all replication partners being down is an expected occurance, perhaps because of maintenance or a disaster recovery, you can force the role to be validated. This can be done by using NTDSUTIL.EXE to seize the role to the same server. This may be done using the steps provided in KB articles 255504 and 324801 on http://support.microsoft.com.

The following operations may be impacted:
Schema: You will no longer be able to modify the schema for this forest.
Domain Naming: You will no longer be able to add or remove domains from this forest.
PDC: You will no longer be able to perform primary domain controller operations, such as Group Policy updates and password resets for non-Active Directory Lightweight Directory Services accounts.
RID: You will not be able to allocation new security identifiers for new user accounts, computer accounts or security groups.
Infrastructure: Cross-domain name references, such as universal group memberships, will not be updated properly if their target object is moved or renamed.

Would another reboot fix this possibly?

by (440 points)

1 Answer

0 votes
by (216k points)


It looks like replication between the two existing Adaxes services is broken. The quickest way to remedy the issue would be to uninstall the 2014.1 service and then install it again. For information on how to uninstall it, see Uninstallation.

If uninstallation fails for some reason or if reinstallation doesn't remedy the issue, you can try the Microsoft's troubleshooting article for this error that's available here: http://technet.microsoft.com/en-us/libr ... 10%29.aspx.


We are still on a Server 2003 functional domain - I'm not seeing the items they're listing in that MS KB article since we don't have Secure LDAP available.

Is that a requirement for this to work?

I tried to reinstall on the first one that was working but it failed with the exact same error.

Would I be better off trying to export the settings from the existing and import them into the new rather than trying to force replication?


Apparently not - I did the export from 2013.1 and then imported that into 2014.1 and haven't had any issues with that particular error.



Thanks for the update. Since you are not going to muse the old 2013.1 service any more, this should resolve the issue.

Related questions

0 votes
1 answer

We are attempting to update from 2021.1 version 3.14.20916.0 to the most current version - 3.14.21404.0. We have two servers in a multiserver configuration once ... Adaxes Service reverts to the previous server that no longer exists and displays the error.

asked Sep 1, 2023 by awooten (60 points)
0 votes
1 answer

I have a custom command that uses powershell to set the room capacity for a resource mailbox in 0365. The command runs without any errors when called manually ... { # Close the remote session and release resources Disconnect-ExchangeOnline -Confirm:$false }

asked Nov 7, 2022 by Kirkvanslyke (50 points)
0 votes
1 answer

Hi, I'm trying to open Adaxes object with Powershell script, and receive "object does not exist" error message. The script is executed remotely (not ... + FullyQualifiedErrorId : DotNetMethodException Any helps will be greatly appreciated. Thank you, Van

asked Apr 24, 2013 by vnguyen (20 points)
0 votes
1 answer

Hello, we have a forest with two trees that hold one domain each. There is a default tree-root trust (transitive, two-way) between the top domains. Since both trees are in ... Sid S-1-5-10 were found". Any help would be appreciated, thank you! Regards HarryNew

asked Oct 8, 2020 by HarryNew (270 points)
0 votes
1 answer

We are in the process of updating our Active Directory Domain Controllers to server 2022 and the Domain/Forest function level. Our concern is that we still have Adaxes ... version of Windows server for our DCs and the Domain/Forest function level of 2016?

asked Oct 11, 2023 by sphoeinix (20 points)
3,386 questions
3,085 answers
545,544 users