0 votes

I am trying to configure Adaxes to talk to my O365 Tenant. Following the guide here - https://www.adaxes.com/tutorials_Active ... ice365.htm - I am getting stuck on the registration stage.

I am required to enter an account that has admin privileges in O365. I have created a service account that has Exchange Admin and User Admin within 365. The account does not have MFA enabled.

I get the following error:

Invalid Credentials.
An error occurred sending the request.

I know the credentials are correct because I can authenticate to Azure using this account.
I have also ensured that MFA is not enabled (I got a different error initially when it was enabled)
Mail-enabling the service account didn't make a difference
I get the same error with my own account (which has the same rights that I have set on the service account)

Is anybody able to help?

by (50 points)

1 Answer

0 votes
by (227k points)
selected by
Best answer

Hello,

To connect to Office 365, Adaxes sends HTTP requests to the following URLs:

https://graph.microsoft.com
https://login.microsoftonline.com
https://outlook.office365.com

Please, make sure that neither of them is blocked by your firewall.

If that does not solve the issue, enable tracing of requests sent to Office 365, reproduce the issue and send us (support[at]adaxes.com) the log file. For information on how to enable the tracing, have a look at the following help article: https://www.adaxes.com/help/?HowDoI.Per ... uests.html.

Related questions

0 votes
1 answer

I have been searching your site, but could not find a list of access rights needed. --- Morten A. Steien

asked Feb 23, 2021 by Morten A. Steien (150 points)
0 votes
1 answer

Our adaxes service account is able to create the mailbox when running our create user business rule, but cannot change any settings like disable OWA. What level of security will it need?

asked Apr 6, 2021 by bstone (50 points)
0 votes
1 answer

Hello, We have an exchange server in a separate forest. When we create the mailbox using a business rule after user creation, the mailbox creates ok. After the user ... multi-forest environment and it made no difference. Thanks for any help you can provide.

asked Nov 2, 2018 by Jasonmh (540 points)
0 votes
1 answer

I have a Business Rule in place that after a new user is created, will create an Exchange mailbox for the user, set the Retention Policy for the user, then send them a ... the correct email address for the user. Is this maybe just a timing issue or something?

asked May 16, 2014 by RickWaukCo (300 points)
0 votes
2 answers

Dear Support, can you advise if it's possible to connect to Adaxes from PowerBI? To have access (read) for the Adaxes custom attributes? Thank you!

asked May 13, 2020 by Dmytro.Rudyi (850 points)
2,797 questions
2,530 answers
6,594 comments
57,120 users