0 votes

Hi,

we are running Adaxes on a MS Server 2008 R2 with IIS 7.5 and we wanted to enable Automatic Login for the self-service part.
We did it exactly the way like it is described in the documents and we also did the SPN part but it refuses to work, the only machine where SSO works is on the server itself where Adaxes is installed.

I should note that we have a AD forrest, consisting out of three domains, where the Adaxes server is placed in the root domain.

by (960 points)

1 Answer

0 votes
by (215k points)

Hello

Are Adaxes Web Interface and Adaxes Service installed on different computers? If it is so, please follow the steps below to fix the issue:

  • On the computer where Adaxes Web Interface is installed open the file C:\Users\All Users\Softerra\Adaxes 3\Softerra.Adaxes.Adsi.dll.config
  • Find the following element <channel ref="tcp" priority="2" secure="true">
  • Add the following attribute to this element:
    <channel ref="tcp" priority="2" secure="true" servicePrincipalName="username@domain.com">
    where username@domain.com is the username of Adaxes default service administrator (the user that was specified during Adaxes installation).
  • Save the file.
  • Restart IIS.
0

Thanks for the tip.

I fixed the issue with this KB article http://support.microsoft.com/kb/326985

0

Looks like Microsoft has moved the article. Is it this one: http://support.microsoft.com/kb/907272 ?

Related questions

0 votes
1 answer

I tested Automatic Login without SSL and it worked fine, but with SSL the Web Interface throws Access Denied error the first time I browser the URL. However, on ... issue? Is there any specific configuration required for making Single SignOn work with SSL?

asked Jul 3, 2013 by sdavidson (730 points)
0 votes
1 answer

Hi Team I need some assitance with creating a report to pull from exchange online all user mailboxes that have automatic replies enabled. I have been attempting to use ... Where-Object { $_.AutoReplyState -ne "Disabled" } | Select Identity, StartTime, EndTime

asked Aug 25, 2021 by Richard_NRL (90 points)
0 votes
1 answer

Hi, We are getting intermittent problems with 2 exchange powershell commands. All the over commands work fine [08/07/2014 19:45:54] Get-CalendarProcessing -Identity "CN=46010248, ... this? I've tried running the command on the mdcexch5r and there is no error.

asked Aug 7, 2014 by darryl82 (40 points)
0 votes
0 answers

Hi Evryone, I am trying to set up an external portal within a new webserver on dmz, and with only access to a webservice created from selfservice. The new webservice is only ... login, only reset password. What I am mising there that its not working? Thanks,

asked Nov 26, 2021 by yagoityd (20 points)
0 votes
1 answer

We have multiple secondary domains that are being managed by Adaxes. Everything seems to be working except self service portal login. We tested with our other secondary domains and those ... other than sign failed. What else can I look at to figure this out?

asked Aug 21, 2020 by mark.it.admin (2.0k points)
2,779 questions
2,512 answers
6,576 comments
26,891 users