0 votes

Hello,

I was wondering if there is an upgrade process from version 2.6.6702 to the latest release? I've read the Release Notes for the latest version of Adaxes, but I don't see an upgrade section; I only see an installation section.
I tried running the new version executable, but it says that there is another version already installed and I didn't get an option to do an upgrade.
If I have to completely remove the previous version, will I lose my current configuration or do I have to manually back them up?

by (60 points)

1 Answer

0 votes
by (18.0k points)

Hello,

To upgrade to a new version of Adaxes you need to perform the following steps:

    1. Backup the configuration of your Adaxes service. For details, see Backup/Restore Service Configuration.
    1. Uninstall the old version.
    1. Install the new version.
    1. Restore the configuration.

The next version will include a GUI tool for backing up and restoring the configuration of Adaxes service and Web Interface. Also, it will be possible to backup/restore configuration using the Adaxes installer.

0

Thanks for your quick reply.

I was able to perform the backup/restore; however, after updating our management consoles (10 users) the "binding" process to the service takes almost five minutes!
I'm using the same server where I had the previous version of Adaxes, so no change in hardware. Even from the server itself, launching the console takes almost a minute during the "binding" process.

Can you help?

0

After restoring the configuration, you need to provide credentials for managed AD domains (in 2011.1 passwords are not stored in the backup file). To do this, you just need to expand the node of your AD domain in the Adaxes Administration Console. Have you done this?

Also, please have a look at the Adaxes Event Log. Are there any errors in this log?

0

I've not tried any of those. Is this done at the server level or per management console? If it's done per management console, what credentials am I using? In the previous version I never had to do that.

Thanks!

0

You need to specify the credentials that will be used by Adaxes to access your AD domain.
The Adaxes service will use these credentials to perform all operations within this domain.

1. Right click your AD domain in the Adaxes Administration Console
2. Select Change/Provide Logon Information

3. Specify the user name and password of an AD account that has administrative privileges in your AD domain.

0

Thanks for your reply.

I checked that, and it's using the default credentials used by the Adaxes services, and that account has domain admin credentials.

As soon as I launch the application, I get the Connecting to MYSERVER....Binding...

That window stays on for almost 5 minutes (I clocked it); then clicking on on any domain OU or object takes a very long time - longer than it used to take in the previous version. This seems to happen mainly on our management consoles.

When I run the management console from the server - the application runs much faster.

0

This is very strange...

  1. Please try connecting to your Adaxes service using the credentials of the default Adaxes service administrator (the one you specified during the installation of your service). Does it take less time to connect?
  2. Are there any errors in the Adaxes Event Log?
  3. Do you use new version of the Adaxes Administration Console?
0

Okay, I had to remove all leftover files/folders from the previous console installation on my desktop (located in my Documents and Settings\MyProfile folder). Re-installed the application and that fixed the "binding..." delay.

All good now, thanks!

0

That's great!
However it is strange. I cannot understand what can cause such delays and we cannot reproduce the issue in our environment...

Related questions

0 votes
0 answers

To upgrade to a new version of Adaxes and keep all configuration settings made in the old version, you need to back up the configuration of your Adaxes ... restore the configuration from the backup files. For detailed instructions, see Upgrade Instructions.

asked Dec 12, 2011 by Adaxes (380 points)
0 votes
1 answer

Hello, The upgrade process is, given my knowlegde, still requiring to uninstall and reinstall the product, importing back then the configuration. I had troubles with that process ... to have a patching process a little bit more easier to apply. Thanks Stephen

asked Feb 18, 2012 by sroux (800 points)
0 votes
1 answer

Can you point me to documentation to upgrade from Adaxes 2019.2 ver 3.1.2.174230 to the current version please?

asked Jun 16, 2020 by msylvester (60 points)
0 votes
1 answer

I think this started happening back in August when we updated to the current version (3.13.18.106.0). We are not sure though because this only affects the web page ... We would prefer not to allow access through a firewall for this. Screenshot of the error:

asked Nov 23, 2020 by mark.it.admin (2.0k points)
0 votes
1 answer

This article states that managment of shared mailboxes is added. https://www.adaxes.com/info_whats-new_2019.1.htm#exchange Where is the details on implementation? It seems like ... mismatch on what you say and what the software does and lack of instructions.

asked Aug 18, 2020 by ComputerHabit (790 points)
2,779 questions
2,512 answers
6,576 comments
26,871 users