0 votes

I am installing a trival version of Adeaxes, during the installation it gives me an error...

Failed to get the list of IIS web sites.
Access is denied.

Only 'Default Web Site' will be available to install the Web Interface.

I am running on a Windows 2008R2 64Bit system. I have two websites configured on the box

Default Web Site
Provisioning

I would like to install it using a different web site and not the default website. Each site is on-line and I have verified that I can browse to a test file inside the site. I am installing as a Domain Admin on the box.

by (20 points)

1 Answer

0 votes
by (18.0k points)

Hello,
The 'Access Denied' error is likely due to UAC turned on.

Try either disabling UAC, or running the Adaxes Installer as Administrator:

runas /user:DOMAIN\administrator "msiexec /i adaxes_x64_en.msi"

0

Thank you, that worked.

0

I tried disabling UAC and I still get the same error. I went ahead and ran the command posted as a domain admin account and still got the same error. It was only after using the builtin AD Administrator account in the command that the install proceeded without the error.

I even tried adding my normal domain admin account as an enterprise and schema admin the same as the built in Administrator account and it still produces the same error.

I'm trying to do the install on Server 2012 R2. I can use the workaround of using the Builtin\Administrator account but I'm curious why it only seems to work using that account.

Thanks!

0

Hello,

On the latest editions of Windows, it is necessary to run installation from the elevated command prompt even if UAC is disabled. To start the elevated command prompt:

  1. Point to the upper-right corner of the screen, move the mouse pointer down, and then click Search.
  2. Enter cmd in the search box, and then right-click Command Prompt.
  3. Click Run as administrator.
0

I still get the same error with UAC turned off and the command prompt run as administrator. The only time I don't see the error about only being able to use the default site in IIS is if I run as the builtin\administrator account.

Strangely enough I don't need UAC turned off I use the Builtin\Administrator account. Using that account in the runas command seems to be the only way to install the sites somewhere other than the default website.

0

This workaround was working in my test environment. I've begun the install in production and even though I'm running this as Administrator and UAC is turned off I'm still getting the error saying it can only be installed under default website because of UAC.

I can verify UAC is turned off by running tasks as administrator and the prompt doesn't show up. I'm not sure what else to try. I'm unable to do the install in my production environment because the web server already has a site in the default website.

Related questions

0 votes
1 answer

Hello I've broke my Adaxes setup after installing AD Certificate Authority Web Services (which use IIS too). I've uninstalled the service but issue is still there. Access to all ... do it since already installed. It's a Windows Server 2019 (Azure VM) Any idea?

asked Aug 3, 2021 by ygini (220 points)
0 votes
1 answer

I'm looking for installation/configuration manuals to determine the installation requirements (prerequisites) for Adaxes. I'd like to install this on two vmware virtual servers running Windows ... ready for the install so I don't waste any of the trial time.

asked Apr 27, 2021 by MRBruce (110 points)
0 votes
1 answer

We've requested a quote for 2500 licenses and plan on downloading a trial. However, I want to be certain of when the 30-day trial starts ticking...upon the initial download of the software, or only after the downloaded software is installed in our environment?

asked Apr 22, 2021 by MRBruce (110 points)
0 votes
1 answer

Hi, I'm trying to fully automate the deployment of Adaxes (using windows DSC ressources). I was able to setup servers with only the front-end features, but cannot ... relevant information in the forum or online about giving the credentials to the installer...

asked Jul 13, 2017 by thomas.laborde (100 points)
0 votes
0 answers

Hello, Where i'm actually working, it seems there is an "old dev" Adaxes environnement which was linked to the AD. The server has been deleted now, but it seems the Windows ... Even if i install a fresh client. Where those parameters came from a GPO i guess ?

asked Apr 26, 2016 by Alexandre (460 points)
2,807 questions
2,541 answers
6,613 comments
64,595 users