0 votes

Whenever i use exchange cmdlets through remote powershell from a script launched by Adaxes, i get this warning message in the execution log:

"Some imported command names include unapproved verbs which might make them less discoverable. Use the Verbose parameter for more detail or type Get-Verb to see the list of approved verbs."
EDIT: This was fixed by adding -DisableNameChecking to the Import-Pssession when connecting to Exchange Servers

Also, when trying to set exchance permissions through a script, i get this error:
"Database is mandatory on UserMailbox. Property Name: Database"
This does not occur when using the exact same command directly in the exchange management shell on the server, or when doing this manually through remote powershell.
EDIT: This was also fixed by adding -DisableNameChecking to the Import-Pssession when connecting to Exchange Servers

Also, when copiyng users, the group membership is NOT copied (yes, the "Copy group membership" is selected)
EDIT: This was fixed by adding -AllowClobber to the Import-Pssession when connecting to Lync Servers

This was NOT present before the upgrade, and the scripts has not changed

EDIT: It seem all my problems were solved now. I won't delete the post, should anyone else experience these problems.

by (960 points)

Please log in or register to answer this question.

Related questions

0 votes
1 answer

Hello, In previous versions I used the instructions in this post Handling child objects to view Bitlocker Recovery Key's for computers. After upgrading to 2013.2 these instructions no longer ... way to view it. Help... this is a critical issue for us. Thanks.

asked Oct 30, 2013 by DFassett (700 points)
0 votes
0 answers

Hi, we recently upgraded to version 2013.1. Everything was working fine. We have multiple websites and noticed, that on custom websites, newly created Active Directory filters do ... THE OU object does not exist". It is a know error? Thanks Regards, Andreas

asked May 30, 2013 by andreasaster (20 points)
0 votes
1 answer

After installing the 2013.2 update the updated template web portals have access to the new reports (recently created and modified groups). These are however not available for our ... two, as I don't really want to have to start again from scratch! Thanks

asked Jan 12, 2014 by firegoblin (1.6k points)
0 votes
1 answer

Can you point me to documentation to upgrade from Adaxes 2019.2 ver 3.1.2.174230 to the current version please?

asked Jun 16, 2020 by msylvester (60 points)
0 votes
1 answer

Hello, I have tested an upgrade from 2017.2 to 2018.2. Everything is fine exept that when I tried to change somethings in a custom web site from /AdaxesConfig I get a ... 2 I restored all web sites from the backup but not the services. Thanks for you help.

asked Oct 24, 2018 by tentaal (1.1k points)
2,599 questions
2,338 answers
6,212 comments
848,487 users