0 votes

Hi,

Having just upgraded my macbook to Yosemite it appears the web interface no longer works. Is Safari 8 supported by the web interface?

Thanks

by (390 points)
0

Hello,

We didn't test Adaxes Web Interface with Safari 8. The browsers that were fully tested with Adaxes Web Interface are Internet Explorer 7.0 and higher, Firefox 2.0 and higher, Opera 8.5 or higher, and Google Chrome.

Nevertheless, could you describe the issues that you are experiencing in more detail (you can also attach screenshots to your post) so that we could understand whether it is a compatibility issue or an issue with the Web interface. Also, have you tried loading the Web Interface in other browsers? Is it accessible from other computers?

0

Hi,

Yes our web interface works in other browsers and works on Safari 7 okay too. An example of an issue is Search. The page sits at the Loading... spinner and doesn't return any results. If I look in the Console window there are errors displayed (screenshot attached)

1 Answer

0 votes
by (215k points)

Hello,

The reason for the issue is that ASP.NET that used as the engine for Adaxes Web Interface does not correctly recognize the Safari 8 browser. To quickly fix the issue, do the following:

  1. Open the folder that contains the Web Interface site that you want to access with Safari 8. By default, Adaxes Web Interface sites are installed to the following folders:
    Administrators:
    C:\Program Files\Softerra\Adaxes 3\Web Interface\Admin\
    Help Desk:
    C:\Program Files\Softerra\Adaxes 3\Web Interface\HelpDesk\
    Self-Service:
    C:\Program Files\Softerra\Adaxes 3\Web Interface\SelfService\

  2. Open a sub-folder named App_Browsers.

  3. Create a new text file in that subfolder. The file name doesn't really matter, but the file extension must be *.browser. For example, safari.browser.

  4. Open the file in any text editor, e.g. notepad.exe.

  5. Copy and paste the following text:

     <browsers>
       <browser id="Safari60_bugfix" parentID="Safari60">
         <identification>
           <capability name="appleWebTechnologyVersion" match="^\d{3,}$" />  <!-- At least 3 digits -->
         </identification>
    
         <capabilities>
           <!-- Same as in "Safari1Plus" -->
           <capability name="ecmascriptversion" value="1.4" />
           <capability name="w3cdomversion" value="1.0" />
           <capability name="supportsCallback" value="true" />
          </capabilities>
       </browser>
    
       <browser id="Safari85_bugfix" parentID="Safari85">
         <identification>
           <capability name="appleWebTechnologyVersion" match="^\d{3,}$" />  <!-- At least 3 digits -->
         </identification>
    
         <capabilities>
           <!-- Same as in "Safari1Plus" -->
           <capability name="ecmascriptversion" value="1.4" />
           <capability name="w3cdomversion" value="1.0" />
           <capability name="supportsCallback" value="true" />
         </capabilities>
       </browser>
     </browsers>
    
  6. Save the file.

  7. If necessary, repeat the same for all the other Web interfaces.

If anything goes wrong, simply delete the file that you've created.

Could you post here a feedback as to whether this helped? We don't have any Macs with OSX Yosemite / Safari 8, so we can't test this solution on premises. If this solution works, we'll include it in future releases.

0

Hi,

Thanks for looking into this, unfortunately that fix made no difference to the issue.

0

Try restarting IIS on the computer where the Web interface is installed.

0

I already did try that.

0

Hello,

The solution we provided above didn't work because IIS didn't recompile the web site for the Adaxes Web Interface. An IIS restart doesn't always cause a site recompile.

To resolve the issue:

  1. Perform the steps listed in OSX Yosemite.
  2. Start the Web Interface Customization tool.
  3. In the Interface type drop-down list, select the Web interface you are having issues with.
  4. Make any changes to the Web Interface. For example, enable or disable the home page.
  5. Click Apply. This will force IIS to recompile the web site.
  6. Undo the changes that you've made and click Apply again.

This should resolve the issue.

0

Hi,

I'm facing the same issue as the creator of this post and I tried your fix but it's not working for me.
Any other ideas?

Regards
Ingemar

0

Hello Ingemar,

Currently, our QA guys are trying to come up with some ideas, but no luck so far. In our environment, the browser file fixes the issue in 100% of cases. We'll update this topic as soon as we have any more information.

0

If the above fix doesn't work, this means that IIS hasn't recompiled information about browsers for the Web interface. As we've found out, there is a bug with browser definition files in IIS: if the App_Browsers folder contains more than 1 browser definition file, occasionally, IIS can ignore changes in all files except the 1st file in the folder. For more information, see section Bugs in the following article: http://forums.asp.net/t/955969.aspx?Mas ... tion+Files.

Since all Adaxes Web Interfaces already have a browser definition file out of the box called ie.browser, when the issue occurs, IIS will track only changes in the ie.browser file. It will ignore adding, removing browser files or making any changes in any files except the ie.browser file.

To work around the issue, you need to force update of browser information in IIS. To do this:

  1. Launch notepad.exe.
  2. Open the ie.browser file for the Web Interface you want to configure. By default, it is located in folder C:\Program Files\Softerra\Adaxes 3\Web Interface\<Web_Interface_Type>\App_Browsers on the computer where the Web interface is installed.
  3. Save the file by pressing Ctrl+S. This will update the modification date of the file which is sufficient to force update of browser information.
  4. If necessary, repeat the same for the rest of the Web interfaces.
0

thanks for the heads-up, I'll wait for further information.

0

Hello Ingemar,

The solution is provided in the OSX Yosemite. One of our customers has already reported that it works.

0

Thanks, that worked for me too!

Regards
Ingemar

Related questions

0 votes
1 answer

Hi All, Did some find solution for OSX and Adaxes to manage password in keychain? In our orgnisation we have an about 200 macs and we face with such problem: users change ... in keychain is still old password. Do you have any ideas how to solve this issue?

asked Apr 27, 2015 by axmaster (510 points)
2,629 questions
2,364 answers
6,272 comments
961,973 users