0 votes

When trying to modify any user settings from reset password to disable or enable I'm getting the error access is denied.
This is only from the helpdesk or admin url's, from the Self service url i'm able to change or modify information and change passwords just fine.

Looking at the adaxes logs i find the following error "Access Control Processor: Access is denied. "

what am i missing

by (50 points)

1 Answer

0 votes
by (220k points)
selected by
Best answer

Hello David,

In Adaxes permissions are granted by Security Roles and native Active Directory permissions are ignored. By default, there are two Security Roles effective for all users:

  • Domain User role – grants all users with permissions only to view all properties of all objects,
  • User Self-Service role - grants all users with permissions only over their own accounts (e.g. change passwords).

For information on how to grant users permissions to modify properties of AD objects, have a look at the following tutorial: http://www.adaxes.com/tutorials_Delegat ... erties.htm.

For information on how to grant users permissions to reset passwords of other users, have a look at the following tutorial: http://www.adaxes.com/tutorials_Delegat ... swords.htm.

Related questions

0 votes
0 answers

Hi Evryone, I am trying to set up an external portal within a new webserver on dmz, and with only access to a webservice created from selfservice. The new webservice is only ... login, only reset password. What I am mising there that its not working? Thanks,

asked Nov 26, 2021 by yagoityd (20 points)
0 votes
1 answer

We have multiple servers in our Adaxes cluster. One of the servers is throwing an error of "Access is denied." before a login page even comes ... step) +75 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +158

asked Aug 27, 2020 by mark.it.admin (1.8k points)
0 votes
1 answer

Since upgrading to 2019.2 I am no longer able to run scheduled reports, either automatically or manually. When looking at the log I see it fails at the "generate report ... is attempting. I can run the report directly with no problem. Can anyone help? Thanks,

asked Nov 21, 2019 by rossb (20 points)
0 votes
1 answer

Hi All, We have a reoccuring "Access is Denied" error for our Web Interface sites. This started frequently after upgrading to 2018 version and frequent reboots seem to clear ... the website, restarted the app pool. Still the same error - any advice? Thanks!

asked Jan 4, 2019 by jmarcellus (50 points)
0 votes
1 answer

Hello, I have tested an upgrade from 2017.2 to 2018.2. Everything is fine exept that when I tried to change somethings in a custom web site from /AdaxesConfig I get a ... 2 I restored all web sites from the backup but not the services. Thanks for you help.

asked Oct 24, 2018 by tentaal (1.1k points)
2,740 questions
2,474 answers
6,475 comments
1,373,632 users