0 votes

Hi,

I installed a new adaxes 2014.1 server and restore web interfaces from another server in 2013.2
When I uncheck Operations in Customize Operations windows, there is no effect on web interface. All enabled custom commands are displayer on the web interface.
More over, it seems that my test user was able to launch every customs commands regardless security roles

Maybe I missed something but it works fine on my 2 others Adaxes servers (in 2013.2)

Thanks in advance

Regards

Sebastien

by (730 points)

1 Answer

0 votes
by (215k points)

Hello Sebastien,

When I uncheck Operations in Customize Operations windows, there is no effect on web interface. All enabled custom commands are displayer on the web interface.

Please make sure that you've selected the correct Web Interface in the Interface type drop-down list of the Web Interface Customization tool.

More over, it seems that my test user was able to launch every customs commands regardless security roles

Did you check this in AD object lists? The thing is that in AD object lists, if a user has sufficient permissions to execute a Custom Command at least on any objects in your Active Directory, the Command will always be displayed for objects of that type. So, for example, if a user has the permission to execute the Deprovision Custom Command at least on one user in your AD, it will always be displayed in grids when users are selected.

However, Custom Commands are executed on the selected objects one by one, and for each object Adaxes will check whether the user has sufficient permissions to execute the Custom Command on it. For those objects that the user doesn't have sufficient permissions, th Access is denied error will be shown.

0

My bad :)

Thanks for your answer.
I would make clean onthe operation list displayed, even for users who have full rights on AD.

Thanks again.

Related questions

0 votes
1 answer

Hello! I've just upgraded our installation of Adaxes to 2014.1, and I'm looking forward to utilising the new features, particularly the O365 Cloud management features. However ... switch (will wait for some feedback), would be greatly welcome. Many thanks, Jay

asked Apr 11, 2014 by jaypaterson (90 points)
0 votes
1 answer

Hello, after upgrading to 2014.1 the web interface is throwing lots warnings pertaining to groups: Failed to build a list of groups, in which user 'Some.Person@domain.local ... very noisy with these warnings. :) Has anyone else experienced this? Any ideas?

asked Aug 29, 2014 by EgotisticalGiraffe (350 points)
0 votes
1 answer

I'm moving from 2013.1 (on Server 2008 R2) to 2014.1 (on Server 2012 R2) and am going from a single server to 2 new servers and will shut down the 2013 ... be updated properly if their target object is moved or renamed. Would another reboot fix this possibly?

asked Aug 26, 2014 by danftasc (440 points)
0 votes
1 answer

Hello, I think I might have found a regression. Starting 2014.1 it is impossible to change the reply address for a user having an Exchange 2003 mailbox. The button "Set ... related to my authorizations; I did test various configuration (admin, ...). Regards,

asked May 2, 2014 by Pierre (750 points)
0 votes
1 answer

Hello, We have several webservices that interact with Adaxes through the ADSI interface. They have been configured and working ... IActiveDirectoryAccess.GetUserByLoginName(String loginName) at ActiveDirectoryAccessClient.GetUserByLoginName(String loginName)

asked Apr 12, 2014 by mbcalvin (140 points)
2,757 questions
2,491 answers
6,523 comments
1,468,998 users