0 votes

How to extend the timeout on the web portal pages, our users on our Hepldesk go call to call to troubleshoot issues, but each time they have to relogin to the portal page each time. Is there a way to extend this time and if so how.

Thanks,
Tony

by (320 points)

1 Answer

0 votes
by (216k points)

Hello Tony,

Yes. To do this:

  1. Make sure that the Web Interface Customization tool is closed.

  2. Open the Web.config file for the necessary Web Interface in a text editor. By default, Adaxes Web Interface sites are installed in the following folders:

    • Administrators: C:\Program Files\Softerra\Adaxes 3\Web Interface\Admin\
    • Help Desk: C:\Program Files\Softerra\Adaxes 3\Web Interface\HelpDesk\
    • Self-Service: C:\Program Files\Softerra\Adaxes 3\Web Interface\SelfService\
  3. Find the following lines in the file:

     <authentication mode="Forms">
       <!-- 
         Warning: The protection must be 'All' because a ticket that is stored in 
         the cookie conains user password in case if the user provides credentials explicitly.
       -->
       <forms protection="All" cookieless="AutoDetect" loginUrl="~/SignIn.aspx" timeout="120" />
     </authentication>
    
  4. The time (in minutes) during which a user says logged in to the Web Interface is determined by the timeout attribute of the forms XML element. For example, if you want a user to be logged in to a web interface for 3 hours, modify the ​forms​ element as follows:

       <forms protection="All" cookieless="AutoDetect" loginUrl="~/SignIn.aspx" timeout="180" />
    
  5. Save the file.

  6. Repeat the same for the other Web Interface types, if necessary.

By the way, currently the timeout is not sliding, which means that the timeout starts when a user logs in and is not reset. In a minor update to Adaxes 2014.1 that will be available in a couple of weeks or so, the timeout will be sliding, which means that each request to the Web Interface from a user will reset the counter.

0

Thanks for the Quick reply. It works great..

0

Well I thought is was working great, I now have users telling me that the timeout is not working the user started her PC and logged in to all her working windows including the web portal, after her initial login she tried to do a search and was forced to login again. The time between login and the second request was aproximate 10 minutes(useing Firefox ver.23). I have replaced the timeout 120 with 960 with the hope that the users would not have to keep relogging in every time they preform a request in the web portal. the time out is even werse in IE.

0

Hello,

What version of Adaxes are you using (including the build number)?

0

we are useing 2014.1 ver3.7.10510.0

0

Hello,

The thing is that Adaxes 2014.1 fixes the issue with the Web Interface timeout only partially. The fix doesn't work in all cases. In the minor update to 2014.1 that will be available in a couple of weeks, we are going to fully fix this (in addition to making the timeout sliding).

0

Any word on when this update may be released? We are in holding pattern for deploying more groups of user to utilize WEB UI until this is soulved, but would like to move forward soon.

0

Hello,

It will be available today, but a bit later. We'll update this topic as soon as it is available.

0

Has this been released yet.

0

Hello,

Sorry for a delay, we had to postpone the release by 2 days. The minor update is already available. You can download it here.

Upgrade Instructions.

For a complete list of new features and improvements, see What's New.

0

We still seem to have an issue with this funtion, we have upgraded to 2014.1 (Nov update) and we still have to relogin. I have set the time out to 540 (9 hours) but still locks out the web portal after about a half hour. Are there any other configurations that need to be updated, or is there a way to remove this lock out funtion all together?

0

Hello,

Hm, that's really weird. Are you sure that you've made the changes for the appropriate Web interface type? Also, are you sure that none of the Web interface files are changed during that half-hour period?

0

this is from the web. config file change that I have in place:

<!-- Authentication settings -->
<authentication mode="Forms">
<!--
Warning: The protection must be 'All' because a ticket that is stored in
the cookie conains user password in case if the user provides credentials explicitly.
-->
<forms protection="All" cookieless="AutoDetect" loginUrl="~/SignIn.aspx" timeout="540" />
</authentication>

Is this correct if I want the time out to be 9 hours?

I am not sure what you mean by " Also, are you sure that none of the Web interface files are changed during that half-hour period?"

0

Hello,

Is this correct if I want the time out to be 9 hours?

Yes, this is correct.

Actually, it seems like we need to take a deeper look into the issue and reproduce it in our testing environment. Can you back up the Web interface that you are having issues with and send the backup file to our support e-mail (support[at]adaxes.com) so that we can investigate it.

For information on how to back up the Web interface, see Backup/Restore Web Interface Configuration.

0

Hello,

We tested Adaxes Web interface with the configuration that you sent us, and everything functions correctly.

We suspect that the cause for the issue may be in the IIS configuration. To check this, can you also send us a screenshot of authentication options of your Web Interface, and also screenshots of the settings for the application pool it resides in.

How to make a screenshot of authentication options for a Web Interface:

  1. On the computer where Adaxes Web Interface is installed, launch Internet Information Services (IIS) Manager from Control Panel \ Administrative Tools.
  2. In the Connections Tree, expand the server that hosts the necessary Web Interface.
  3. Expand Sites.
  4. Expand the web site where the Web Interface is hosted.
  5. Select the web application for the Web Interface type that you are experiencing issues with.
  6. Double-click Authentication.
  7. Send us a screenshot of the page that appears.

How to make screenshots of settings for an application pool where a Web Interface resides:

  1. On the computer where Adaxes Web Interface is installed, launch Internet Information Services (IIS) Manager from Control Panel \ Administrative Tools.
  2. In the Connections Tree, expand the server that hosts the necessary Web Interface.
  3. Select Application Pools.
  4. In the middle view pane, select the application pool that hosts the web application for the Web interface type you need.

    Note:To view all web applications that an application pool hosts, select it and click View Applications.
  5. Click Recycling.
  6. Send us a screenshot of the dialog box that appears.
  7. Click Advanced Settings.
  8. Send us screenshots of the dialog box that appears.

Related questions

0 votes
1 answer

Hi team, currently the loading of "My managed objects" is timing out for some users after exact 1 minute with error DevTools showing me 504 Timing I assume its because of ... users each time I open homepage its loading again and again and take some times.

asked Dec 20, 2023 by wintec01 (960 points)
0 votes
1 answer

Try to look into extending the timeout of the web interface on Adaxes

asked Jul 7, 2022 by Vish539 (310 points)
0 votes
1 answer

What is the correct way to increase the timeout for web user interfaces?

asked Jan 20, 2014 by BradG (950 points)
0 votes
1 answer

Hello, Can you tell me how I might be able to increase the timeout setting in the Adaxes Web Interface? We have a couple Custom Commands that take a little while to ... size of the environment and the Web Interface is timing out before the tasks can complete.

asked Jan 14, 2013 by mdeflice (350 points)
0 votes
1 answer

would like to know the method to provide a button to security Q&amp;A reset for enrolled users to Adaxes Admins via Web UI

asked Mar 21, 2023 by Vish539 (310 points)
3,298 questions
2,996 answers
7,668 comments
544,227 users