0 votes


i'm certain my credentials are correct.
I get the message invalid credentials. could not load file or assembly c:\windows\system32\windowsPowerShell\v.1\Module\MsOnline\Microsoft.Online.Administration.Automation.PSModule.dll or one of its dependencies. this assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded"

I followed the doc to install assistant, then Azure AD but no cigar.
I've also updated PS to v3, no cigar.
I've also confirmed that that module is in that location.

Please advise.


by (1.7k points)

link posted here, did not fix my issue

MSOL Issue

1 Answer

0 votes
by (216k points)
selected by
Best answer


The thing is that recently Microsoft has upgraded the 64-bit version of the Azure AD Module. The new version of the module targets the .NET Framework 4.0 runtime, however Adaxes targets .NETFramework 2.0 runtime, which makes it impossible to load the new version of the Azure AD Module in Adaxes. We are planning to switch Adaxes to a higher .NET Framework runtime version in Adaxes 2016.1, but this can't be done that easily and requires a lot of work.

To work around the issue:

  1. Download version 8362.1 of the module from this page: ‚Äčhttp://social.technet.microsoft.com/wik ... story.aspx.
  2. Uninstall the version of the module that you have.
  3. Install version 8362.1.
  4. Important: Restart Softerra Adaxes Service.

ok thanks.
I was able to move forward.
for clarification regarding associated AD Scope - is this referring to the object/containers marked for sync within DirSync? These are the same objects that should be added within Adaxes when registering O365?


The AD Scope of a tenant defines where in Active Directory an object must be located to be associated with your tenant. If an object falls within the AD scope of the tenant, you will be able to modify the Office 365 and Exchange Online properties of the object via Adaxes.

If your AD is synchronized with Office 365, it is recommended to set the AD scope of the tenant in line with AD sync filtering settings, though it is not a requirement.



I am testing permissions etc and I am getting "failed to reset pwd in office 365. you cannot reset a pwd for a federated users".
I did enable the synchronizations, but I am wondering if this message b/c said role does not have office 365 permissions?
This particular user should not have office 365 permissions in a sense, so will I run into this every an AD account pwd is reset?



When you enable the Synchronize passwords option for a tenant, that means that Adaxes will attempt to set passwords for Office 365 accounts directly in Office 365.

However, in federated environments, you are not allowed to set user passwords in Office 365. In such environments, passwords can be set on-premises only and need to be synchronized to Office 365 with the help of DirSync or Azure AD Connect. If you have a federated involvement, we recommend disabling the Synchronize passwords option.


Help please,

Have installed Adaxes 2017.2, restore existing config to this new install.
Now am trying to register 365 Tenant. Have installed the latest AAD powershell module, ( - AzureAD & - MSOnline) & but error keeps recurring that need to install AAD module on this server .

from reading through forum this was an issue with earlier version of Adaxes and was being uprated to use newer .Net. Is there still an issue with PS module versions am able to use PS to connect to O365 with no problems.

Service has been restarted numerous times.

Any advice would be greatly appreciated


Hello Alex,

For Adaxes version 2017.2, you need to use version 8362.1 of Microsoft Azure Active Directory Module for Windows PowerShell. For information on where to find the required version, see the following help article: http://www.adaxes.com/help/?HowDoI.Perf ... rO365.html. Newer versions of the module will be supported starting from the next major release.


Hello Alex,

The new version of Adaxes that supports new versions of Microsoft Azure Active Directory Module for Windows PowerShell is available. You can download the new version here.

Upgrade Instructions

What's New

Related questions

0 votes
1 answer

I tried two times to update our perfectly working Adaxes instance (2022.1) to the newest version. Update process doesn't show any errors. Same applies for restore of ... service is running fine, so there is clearly some problem with permissions/access. Thanks!

asked Jan 22, 2023 by KIT (910 points)
0 votes
1 answer

I have setup a custom command to move a mailbox from on site to O365 using https://www.adaxes.com/help/?HowDoI.Per ... mO365.html and I'm getting the following error ... deatils OS: Windows server 2008 r2 Exchange: 2013 Adaxes details: 2017.2 3.8.14823.0

asked Jul 1, 2019 by hgletifer (1.3k points)
0 votes
1 answer

Hello, I have some AD Groups I would like to exclude from a business unit I'm using. I have standard group names across multiple OUs, some should be a part of the ... than simply having a working exclude query. Any thoughts on how I can get this working?

asked Mar 24, 2016 by drew.tittle (810 points)
0 votes
1 answer

I'm currently running a SQL SPROC from within powershell, getting a value, and attempting to assign that value to an AD attribute. Everything goes fine getting the value, but ... avoid calling PS from within PS to load the module and run the command. Thanks!

asked Feb 3, 2017 by gmadd13 (50 points)
0 votes
1 answer

Hello, I'm attempting to automate a part of our user creation/modification process and I've created a script that works on the Adaxes server in PowerShell but when I ... ? The Quest Powershell commands are installed on the Adaxes server as well. Thank you!

asked May 20, 2014 by mmackay (50 points)
3,430 questions
3,127 answers
546,252 users