0 votes

I created a new interface...on the Home Page Action, it only has new user.
after the fields are filled out, I get "name is not specified for the new object".

Please advise.

by (1.7k points)

1 Answer

0 votes
by (215k points)

A user cannot be created without the Name property specified. For users, the value of the Name property always equals to Full Name. If you removed the Full Name property from the user creation form together with the properties it consists of (by default, First Name and Last Name), you will not be able to create users.

As a workaround, you can add the property to your Home Page Action as a predefined field.

For instructions on how to do this, see Step 4 under Create New Object in Configure Home Page Actions.

0

Can you also send us the file that you modified per the instructions in the article?

0

Business Rule issue:

Sorry, our mistake. The 2nd set of actions/conditions must be joined with an AND, not OR.

0

Thanks.

file sent.

0

The file looks OK. Try restarting Adaxes service.

However, keep in mind restarting Adaxes service will not affect the Approval Requests that have been created before restarting the service. The new friendly names will apply only to Requests generated after restarting the service. The thing is that the operation description is generated by Adaxes service (that's why you also need to restart the service) at the time when the Request is created. After that, the Web interface simply shows the description that was generated at that time.

0

good to go.
script works and after restarting the service, friendly shows up as expected.

thanks again.

Related questions

0 votes
0 answers

I have been getting the following error when running the built in user creation script. This has worked fine up until about 2 months ago. As you can see Adaxes sees my ... error. The account that I am using has the correct permissions to Exchange as well.

asked Dec 9, 2020 by joshua.velez (20 points)
0 votes
1 answer

Hi all, I want to create an external Username (username-ext). Loginname is the same as the initials. Changing the intiakls -> intials-ext ... CommandPipeline.Actions.ActionBase.Execute(ICommand command) --- Ende der internen Ausnahmestapel├╝berwachung ---

asked Jun 13, 2016 by massimo.ibba (450 points)
0 votes
1 answer

Hi When one of our admins create a user through the webinterface, the following error appears, and the user is not created: Access to the attribute is not permitted because ... is owned by the Security Accounts Manager (SAM). (Server: domain.local) Any ideas?

asked Jun 4, 2013 by kjesoo (960 points)
0 votes
1 answer

Hello, We have hybrid setup with Azure AD sync. Sometimes when creating a user, we face below warning where in user is just created on-prem and not on o365. This is the ... happens after couple of user creations. Please let me know if there is any fix. Thanks!

asked Feb 3 by sarang.raval (20 points)
0 votes
1 answer

Hello, We are currently allowing users to submit requests for new user accounts within the domain. By default, the logon name is being formatted as %firstname%.%lastname% However this ... pre-Windows-2000 user logon name. Is there a way to work around this?

asked Dec 11, 2020 by sirslimjim (330 points)
2,599 questions
2,338 answers
6,212 comments
843,702 users