Skip to content

IAdmPowerShellVersionInfo

The IAdmPowerShellVersionInfo interface provides information about the minimum required version of Microsoft PowerShell.

Inheritance: The IAdmPowerShellVersionInfo interface inherits from the IUnknown interface.

Note

To get the IAdmPowerShellVersionInfo interface, use one of the following approaches:

  1. Bind to the Service Settings container using the “ServiceSettings” alias.
  2. Create an instance of the AdmPowerShellEnvironment class.

    How
    [Reflection.Assembly]::LoadWithPartialName("Softerra.Adaxes.Adsi")
    
    $psEnvironment = New-Object "Softerra.Adaxes.Interop.PowerShell.AdmPowerShellEnvironment"
    
    using Softerra.Adaxes.Interop.PowerShell;
    
    class Program
    {
        static void Main(string[] args)
        {
            AdmPowerShellEnvironment psEnvironment = new AdmPowerShellEnvironment();
        }
    }
    

Properties

Details

MinimumRequiredVersion

Gets the minimum required version of Microsoft PowerShell.

  • Type:
  • String
  • Access:
  • Read-only

MinimumRequiredVersionInstalled

Gets a value indicating whether the minimum required version of Microsoft PowerShell is installed.

  • Type:
  • Boolean
  • Access:
  • Read-only

Requirements

Minimum required version: 2018.1